Lab 3 – QGIS Plugins and Analysis

Skills: View kml data, work with plugins, do some basic analysis,  & join tables

For this exercise you’ll be making a map of County Highpoints for New Mexico.  What are County Highpoints?  Well for many years hikers and climbers have undertaken task of climbing the highest point in a State.  There's a good chance many hikers can name the highest point in the State, even if it isn’t a goal to reach it.  The following description of County Highpointing was taken from Summitpost.org.  

BACKGROUND:

County Highpointing (or COHPing) takes this to the next level.  It is the pursuit of standing atop the highpoints of the 3,142 counties within the 50 United States. How one gets there is not so important, you just have to stand atop it (or put any body part over the top). Most counties have obvious points or summits that can be recognized as the highpoint, while those at lower elevations may have dozens of possible locations, all of which are required to be reached in order to claim an ascent. Add to this that a county is a man-made political boundary often without consideration of the physical terrain that underlies it, and you can see what gives this hobby the aura of the bizarre among climbers and other outdoor enthusiasts. Probably no other outdoor pursuit will do more to entice you to visit areas of the state or nation that you would never have considered otherwise, and therein lies the reason for its growing popularity.

There are many county highpoints that are less than thrilling and don't even represent the best highpoint in a specific county. Yet there are others that will make you work for every foot and are great mountains to climb. The Grand Teton is a county highpoint, as is Mt. Rainier and Mt. Hood. Perhaps we can share our enjoyment of county highpointing by pointing out some of the difficult ones that aren't lofty or alpine but yet are hard and difficult to get to the top of. Little Blue Peak in Yolo county California comes to mind. An excellent resource on this already exists at the County Highpointers website but since Summit Post is really oriented to the peaks and mountains, this site will try to serve by pointing out those county highpoints that are true mountaineering /climbing challenges as well as good hiking efforts.

We are going to use the land ownership map of New Mexico completed in Lab 2 which already contains three useful layers: county boundaries, land ownership & a shaded relief image.  

1. Open up your QGIS project from Lab 2.  Go to File Save Project As… and save it as County_Highpoints in the Lab 3 folder.  This way we’ll still have our original Lab 2 project.

2. Next we’ll download some data needed for the project: the county highpoints for New Mexico.  Go to http://www.cohp.org/n

 HYPERLINK "http://www.cohp.org/nm/new mexico.xml" \n _top
m/new%20mexico.xml This is the “official” County Highpointer website.  You’ll open the page for New Mexico.  It has lots of useful information on New Mexico’s highpoints including trip reports for each county.  What we’re interested in is GIS data.  They don’t have the data as a pure GIS format, however, there is a link to download a Google Earth layer.  Scroll down until you see a couple of horizontal bars with a link to Google Earth.  Right click on the link and Save Link As… to your lab 3 folder.  

3. This is a KMZ file which is compressed KML, the Google Earth format.  KML is a special form of XML called keyhole markup language.  QGIS with OGR can only deal with standard KML, not compressed KMZ.  So first you’ll uncompress the file.  Open Windows Explorer and navigate to the lab folder where you download the nm.kmz file.  Right click on the KMZ file and with 7 Zip uncompress the data.  The nm.kml file is extracted.  

4. Go back to your QGIS project.  Hit the Add Vector Layer button and browse to your lab folder.  Change the Files of type: to KML.  Unlike ArcGIS, with QGIS you can add KML directly to the map with no conversion!   The County Highpoint website states that: Of the 33 counties in New Mexico 2 pairs share common highpoints.  That means that some counties highpoints occur on the boundary line with a neighboring county making it the highpoint for both counties.

5. Change the symbology of the highpoints to red triangles with a back outline. 

Open the layer properties  Style tab  Change button
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The Symbol properties window opens.  You can choose from a variety of symbols by choosing the Symbol layer type.  We'll use Simple marker.

Choose the triangle with a red fill, black border and size of 3.
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6. Insert a screen shot of your QGIS project with the symbolized highpoints kml layer.

ANALYSIS & PLUGINS

Now let’s do some analysis.  We’ll be loading a plugin.  QGIS uses plugins to add new capabilities and tools.  Think Extensions in ArcGIS.  Basically, a plugin is a loadable module that can be added and removed from QGIS.  Plugins are written by developers either in Python or C++.  There are both official Core QGIS plugins and user repositories with plugins that users have created and shared.  One resource for plugins is the QGIS plugin website: http://www.qgis.org/wiki/Python_Plugin_Repositories.  

However, the most thorough and current source seems to be the QGIS 1.6 User Manual.  Go to http://www.qgis.org/en/documentatio

 HYPERLINK "http://www.qgis.org/en/documentation/manuals.html" \n _top
n/manuals.html and download the QGIS 1.6 Users Manual.  This is one of the best resources as you run into questions while working with QGIS.  Plugins are described in Section 9 on page 119 of the manual.  The QGIS documentation is quite good and answers to many questions can be found here.  Remember, working on the documentation is one way non-programmers can contribute to open source projects. 

The Plugin Manager gives you access to all Core Plugins allowing you to load and unload them.  External plugins can be installed and directly activated or uninstalled using the Plugin Installer which is itself a Core Plugin.

7. Go to the Plugins menu  Manage Plugins.  The Core Plugins will be listed.  Scroll to the bottom and click the check box next to fTools (bottom of the list).  This loads the plugin.  Also check the box for the Plugin Installer.  Click OK.  You’ll notice that a new Vector menu has been added.  This is the fTools plugin.
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8. Go back to the Plugins menu  Fetch Python Plugins.  This item was added by enabling the Plugin Installer.  The QGIS Python Plugin Installer opens.  All user contributed plugins are written in Python.  Python is an open source scripting language that is also used by ArcGIS.  Obviously knowing a little Python can be a useful skill.

The Python Plugin Installer lets you browse for additional user created plugins and allows you to install them.  Once installed you can manage user created plugins via the Plugin Manager.  Some of these have dependencies and require other libraries or pieces of software to be installed.  Close the Installer.

9. We want to know how far each highpoint is from the CNM GIS lab.  There is a point shapefile in the Data folder for this lab.  Add the CNM_GIS_Lab.shp to your QGIS project.

10. Go to the Vector menu.  Look through the available tools.  Any ideas on which tool you’ll use to calculate the distance from CNM to each highpoint?

11. The CNM GIS lab layer is in UTM, zone 13, nad83, like our QGIS project, the shaded relief layer and the land ownership layer.  Remember that the counties are in GCS and are being reprojected on the fly.  The county highpoints are also in GCS.  NOTE: all KML is in GCS.  To determine the distance between CNM and each highpoint we’ll want both layers (CNM & the high points) to be in the same SRS.  Right click on the Waypoints layer and select Save as…  Save it as NM_highpoints.shp.  During this step we can also reproject the data.  Click the Browse button next to CRS and set it to UTM zone 13 NAD83.
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12. Once it has been exported, add the new data layer to your project.  Symbolize it as you had done with the original KML waypoints layer.  You no longer need the original KML Waypoints layer, remove it by right clicking on it and choosing Remove.

13. Go to the Vector menu  Analysis Tools  Distance Matrix.  This tool measures distances between two point layers, and outputs results as a)Linear distance matrix, b) Standard distance matrix, or c) Summary of distances.

14. You’ll choose a linear distance matrix which will result in the distance to each highpoint as a separate record in a table.  The output will be a comma delimited text file (*.csv)

15. Set up the Distance matrix form as shown below, and save the csv to your lab folder. Once you get the message that the matrix was created, close the Distance matrix window.
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USING NOTEPAD++

16. Find the output csv file in Windows Explorer.  Right click on it and chose Edit with NotePad++.  This is an Open Source analog to Notepad but substantially more sophisticated.  You’ll see that there are three fields: Input ID (CNM point ID), Target ID (high point name) and Distance (in meters).  We'll use Notepad++ a lot in the web portion of the course.  For now close Notepadd++

JOINING TABLES

17. You need to join the linear distance matrix table to the NM highpoints.  A new feature in QGIS 1.7 allows you to do this easily.  First you need to add the linear distance matrix csv table to your project.  Click on the Add vector layer button. You will need to filter by Comma Separated Values or just choose All files to see your csv file.

18. The table is added to your project.  Right click on the table and open it.  Put a screen shot of your table here.  What field will you use to join this to the NM_highpoints layer? 

Close it when done.

19. Open the Properties of the NM highpoints layer and click on the Joins tab. Click the [image: image6.png]®



 button to add the table and create the join.  Choose the Join field and the target field in the NM highpoints layer.  If you're not sure what fields to use open both tables again and determine which fields the join should be based on.

20. Once you're done take a screenshot of  the NM highpoints attribute table with the joined data. The distance field is now virtually joined within your QGIS project.  

WORKING WITH TABLES

21. The distance data is in meters.  We want the distance in miles not meters.  To make changes to the table we’ll enter edit mode just as we would in ArcGIS.  
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22. Now click on the New Column button.  Call it Miles, make the type decimal and give the field a width of 5 and a precision of 1. Click OK.
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23. Now click on the Open field Calculator button

24. This again is very similar to the ArcMap analog.  Click Update existing field and choose your field miles. You’ll calculate the Miles field to Distance multiplied by the conversion factor 0.000621371 (meters to miles).  You may need to click on the table to have it refresh and show the new values.  Voila we have a field showing the number of miles from our lab to each county highpoint. Toggle out of editing mode by clicking on the edit button.  Click yes to save your changes.

Insert a screen shot of your attribute table with the new Miles field populated.

25. Click on Advanced search.  This opens up a SQL editor.  

How many highpoints are within 100 miles of the CNM lab?____________

BUFFERING

26. Finally we’ll buffer the CNM GIS lab layer by 100 miles to get a visual on how far that is.    Go to the Vector menu  Geoprocessing tools  Buffer(s). We’ll have to enter the units in coordinate system units (meters).  100 miles = 160,934.4 meters.  Increasing the Segments to approximate gives a smoother output.  Put the value at 10.  Once you have the form filled out click OK and click yes when prompted to add the layer to QGIS.
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27. Finally change the symbology of the buffer to a red line with no fill.

FINAL PRODUCT

28. Make a map of your result using the Print Composer like you did in Lab 2. 

29. Insert your map here.

Developed by Kurt Menke, GISP,  Bird's Eye View GIS and funded by the GeoTech Center
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